To be able to successfully use the Immutable X Marketplace and Immutable X Link, the following systems are required:

  • Operating System: Any desktop computer operating system is compatible.

  • Browsers: Chrome, Firefox, Brave, and Edge

  • Wallets: Set yourself up with an Ethereum wallet like Metamask (or any wallet that can be managed via Metamask import), or a Magic Wallet.

Did this answer your question?